Joomla! Multiple Vulnerabilities

If you are using Joomla version 1.0.10 or less, it’s time to update again. According to many security advisories, it’s got high known and unknown impacts.

Description:

Some vulnerabilities have been reported in Joomla!, where some have unknown impacts, and others can be exploited by malicious people to conduct cross-site scripting attacks and bypass certain security restrictions.

1) Some input validation errors exists in the “mosMail()” and “JosIsValidEmail()” functions.

2) An unspecified error exists in PEAR.php.

3) An unspecified error exists due to globals.php not being included in administrator/index.php.

4) Insufficient access control checks exists due to missing defined( ‘_VALID_MOS’ ) checks and certain errors in the Admin “Upload Image”, Admin “Popups”, and “com_content” functionalities.

5) Certain unspecified errors in the “do_pdf” functionality and in the handling of the emailform com_content task can be exploited to bypass the user authentication process.

6) Some unspecified input passed via the Admin “Module Manager”, Admin “Help”, and Search functionalities isn’t properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user’s browser session in context of an affected site.

Some other security related issues have also been reported.

The vulnerabilities have been reported in versions prior to 1.0.11.

The solution is to update it ASAP.

no responses for Joomla! Multiple Vulnerabilities

    Leave a Reply

    Your email address will not be published. Required fields are marked *